RTFM: the missing dot in CNAME

Until today yesterday, I still hesitated to adopt the feed aggregation service from FeedBurner. The main concern is the branding. I would rather secure the feed under the umbrella of my own domain than give it to a bunch of geeks in the silicon valley, no offense, even though the company is most unlikely to go bankruptcy tomorrow and they respect “Do not be evil” motto.

FeedBurner respects such kind of concern and they give the Pro feature, aka you have to pay the premium, MyBrand for free. The only action you should take is to add a CNAME entry in your DNS server: feeds CNAME feeds.feedburner.com. My scenario is a little bit complicated here. This website is hosted in Jumpline.com while the domain name is registered in 1and1. So I assumed that the CNAME should be added in the 1and1 side as this:

1and1 DNS console - Edit CNAME
1and1 DNS console - Edit CNAME

It seemed not working, so I contacted the customer service twice, and they assured me they took care of it, and it would take a little bit of time for DNS propagation. I also tried to update the CNAME in Jumpline’s DNS control panel, and it kept complaining as this:

Error message of Jumpline DNS console
Error message of Jumpline DNS console

Eventually, this yesterday morning, I contacted the custom service of 1and1 again, and this time the gentleman confirmed that they could do nothing here and I needed to contact my web hosting company instead. The first time I contacted Jumpline, the custom service representative pinpointed the bug: the very last dot in the domain name is missing.

What a stupid mistake! If I could take a little bit more time reading the help page of FeedBurner or more adventurous to RTFM of BIND, I would not waste the time for the pleasant phone conversation with technical support.

Never, ever oversee the code however confident you are.